Polygon Mumbai relay deployment issues

Hi,

I tried to install Relay on Google Cloud by following instructions at Tutorial: Running a Relay Server for Fun and Profit | Documentation and I can get to the point of getting a JSON from https:///gsn1/getaddr where ready: false.

However, the issue is when I attempt to register the relay with the Relay Hub in accordance with the instructions via “docker run opengsn/cli relayer-register …” I see the following


Registering GSN relayer at https://vegan-nft.duckdns.org/gsn1
info:    pingResponse: {"relayWorkerAddress":"0x74c06ea99b99362909918200df6c046730c118ac","relayManagerAddress":"0xcdc231c5473f079e0a99335175f85a0229188e9f","relayHubAddress":"0x6646cD15d33cE3a6933e36de38990121e8ba2806","ownerAddress":"0xE5C9e41248aEe0BA21f60EFA00aEF8aBb68d9d8d","minGasPrice":"2000000000","maxAcceptanceBudget":"285252","chainId":"80001","networkId":"80001","ready":false,"version":"2.2.5"}
current stake= 0
Funding relayer
Failed to register relay: only replay-protected (EIP-155) transactions allowed over RPC

Thanks a lot for your help!

Same problem on Matic mainnet.

Please check your configuration with:

1 Like

Yep, I tried with Matic’s suggested configuration, FYI we also have one running GSN relayer on rinkeby.

I googled for the error and I found that we must set chainId in web3 sendTransaction methods to avoid this error.

Fixed in opengsn/cli:2.2.6 - run it with:

docker run --rm -ti -v $PWD:$PWD \
    opengsn/cli:2.2.6 relayer-register ...
1 Like

Thanks, this saved me too!

1 Like

excuse me i have u question to you, how can i dm u?

1 Like

You can dm here in opengsn.

1 Like

nemidoonam chera nemishe message bedam nist baram iconesh, mishe shoma dm bedii ya telegrametoono bedid?!