Gsn deploy on Heco(Huobi Chain) got error

Hi, Guys, I am deploying GSN on heco (Huobi Chain) network(Cloned from Ethereum like Binance Smart Chain). I deployed the contracts first and then start rdc. the host is: gsn.bitcv.net

I follow the tutorial here Tutorial: Running a Relay Server for Fun and Profit | Documentation , everything looks fine. But where I browse the page https://gsn.bitcv.net/getaddr ,I got 404
and browse https://gsn.bitcv.net/gsn1/getaddr, I got 502.
router error log is here:
router | 172.18.0.3 - - [17/Feb/2021:03:15:07 +0000] “GET /gsn1 HTTP/1.0” 301 169 “-” “Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36” router | 172.18.0.3 - - [17/Feb/2021:03:15:11 +0000] “GET /gsn1 HTTP/1.0” 301 169 “-” “Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36” router | 172.18.0.3 - - [17/Feb/2021:03:15:11 +0000] “GET /gsn1/ HTTP/1.0” 499 0 “http://gsn.bitcv.net/gsn1/” “Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36” router | 2021/02/17 03:15:15 [error] 8#8: *58 connect() failed (113: No route to host) while connecting to upstream, client: 172.18.0.3, server: , request: “GET /gsn1/ HTTP/1.0”, upstream: “http://172.18.0.2:80/”, host: “gsn.bitcv.net”, referrer: “http://gsn.bitcv.net/gsn1/” router | 172.18.0.3 - - [17/Feb/2021:03:15:15 +0000] “GET /gsn1/ HTTP/1.0” 502 559 “http://gsn.bitcv.net/gsn1/” “Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36”

where I ping, 172.18.0.2 is not available.

When look into the logs with “rdc logs” command, I found some logs like this:

gsn1_1 | debug: Created logger for ; remote logs collecting: false
gsn1_1 | getVersion(hub) - no version found
gsn1_1 | Starting GSN Relay Server process…

“rdc config” to get config is as following:
services:
gsn1:
environment:
config: /app/config/gsn-relay-config.json
port: 80
relayHubId: hub
url: https://gsn.bitcv.net/gsn1
workdir: /app/data
image: opengsn/jsrelay:2.1.0
restart: on-failure
volumes:
- /data/gsn/dockers/relaydc/gsndata/gsn1:/app/data:rw
- /data/gsn/dockers/relaydc/gsndata/manager:/app/data/manager:rw
- /data/gsn/dockers/relaydc/config:/app/config:ro
https-portal:
environment:
DOMAINS: gsn.bitcv.nethttp://router
STAGE: production
image: steveltn/https-portal:1
ports:
- 443:443/tcp
- 80:80/tcp
restart: always
router:
command:
- gsn1
container_name: router
image: opengsn/prefixrouter
ports:
- 8080:80/tcp
restart: always
version: ‘3.0’

Can any one tell me is it possible to support huobi chain like this? How do I fix this. any help will be appreciated. Thank you very much.

I fixed this problem with replace versionRegistryAddress with replayHubAddress. Thanks.

Yes, the setup is missing one item, and that’s putting the hub address into the registry.
You can bypass by specifying the relayHubAddress directly in the configuration.
This means that a change in the contract will require manual update of the relayer’s configuration.

Thank you for your response. Now It looks like I got everything fine and can see ready from the json result. https://gsn.bitcv.net/gsn1/getaddr
But I cannot see it in the list https://relays.opengsn.org/
is this right?
Thanks again.

I will add it, when you complete the deployment.
Please make sure all contracts have their source Verify&Published .
then you can push a PR against git@github.com:opengsn/gsn-relays-view.git to add it.
see the src/networks.js file

I already verified the contracts and created a PR. the contracts and verified code link are attached at the PR message. Thank you for your great work!