Error in worker, when running relayer-register

Hi,

I deployed gsn contracts to my testnet, and started Relay Server v. 2.2.6.
Now, when I run relayer-register, it gives me the error:

error:   error in worker: account not activated gotBlockNumber: true undefined
debug:   queried node for last active server event, found in block undefined
debug:   will attempt registration: isRegistrationPending=false isRegistrationCorrect=false forceRegistration=false
debug:   will not actually attempt registration - prerequisites not satisfied
...

at first run.

info:    setting relay owner 0xc3a8119e77803a306bCf250dB89D9EEd89842aF3 at StakeManager 0x28faE998401e46785b5cb8a82CD3e43B86f2007b
httpServer: Error: Can't insert key 0x50cfb53fbad6d45c577b49ef83de047e37b95f2bc82672b4eb3ffda3daabf4b3, it violates the unique constraint

and a bunch of mistakes in binary-search-tree and nedb modules in the following runs.

Then console says:

error:   error in worker: Can't insert key... (same error)
...
debug:   Not registered yet

In other terminal where register command running:

Waiting 10000ms 0..5/5 for relayer to set 0xc3a8119e77803a306bCf250dB89D9EEd89842aF3 as owner
Failed to register relay: RelayServer failed to set its owner on the StakeManager

What i already tried to do:

  • Running Relay Server with relayer-run command and docker image (both versions 2.2.5 and 2.2.6 for cli, 2.2.5 for docker)
  • Running relayer-register with cli, and ./dockers/cli/gsn relayer-register
  • Running server and register command in all combinations and with sudo

btw i use gsn from github master branch | cli and relay server from yarn add installation
How can i solve this? Help please.
My os is macos monterey, if it matters.

UPD: that was happening due to the network policy, and there’re no errors in cli I suppose.