Deploy via command line tools issue

Hi,

I tried to deploy GSN contracts with command-line tools to my custom test network (not localhost) following this instructions: Documentation

The problem is that deploy command returns “Unknown account” error, which I suppose is coming from sending an unsigned transaction (no interaction with private key holder, signer, e.g. metamask).

So, the question is: how can i use “npx gsn deploy …” in such a way that this will work in my case?
And if this option doesn’t exist, is there any js example, which i can take as basis to create deployment script?

Your should supply a mnemonic file using the “-m” command line argument. Then the tool will be able to sign the transaction

Yeah, that works! Thanks a lot !

@drortirosh Can you please help me a little more. Now it gives me error:

Error: only replay-protected (EIP-155) transactions allowed over RPC 

As far as I understand it has something to do with chainId, isn’t it?
How can I solve this problem?

UPD: Solved this by adding chainId in CommandsLogic.js file, and by setting gasPrice arg. Thanks again.

yes, its a known issue. glad you find a way to work around it.
We’ll be fixing it for the next release of GSN.

1 Like